Troubleshooting

Following are the most common problems that you may face while using SmartTag and resolutions to them.

  1. “Edit form” is not displaying the relevant tags

    Please check the document library settings, and check if SmartTag is enabled and appropriate columns are configured. For further information please refer SmartTag settings WiKi Page
  2. After all proper configuration still, document content is not getting scanned

    Please ensure that you have IFIlter installed for the respective document, cross check the required terms in term store and Relevance and Word count setting.
  3. Command line utility is slow

    Try increasing number of threads,  also please use this utility whenever you have enough RAM available. We have successfully tested it for documents > 30 MB in size. Its able to Tag these documents in 3 Seconds scanning first 1000 words and Comparing with 118 terms.
  4. Web server performance is slow

    Please ensure that you are using a latest hardware and enough RAM.
  5. On any kind of exception, SmartTag logs those inside SharePoint ULS logs. Please check the server log files for further investigation.

If you are not able to find the your problem above please comment, we will try to reply/add solution to respective issue.

Last edited May 20, 2011 at 7:58 PM by yojoshi, version 2

Comments

brwalias Jan 10, 2013 at 9:10 PM 
Getting same error:

"Error occured in LoadTerms ExceptionType: 'NullReferenceException' ExceptionMessage: 'Object reference not set to an instance of an object.' StackTrace: ' at SmartTag.Common.Taxonomy.TaxonomyHelper.LoadTerms(SPField column)' Source: 'SmartTag.Common' TargetSite: 'System.Collections.Generic.List`1[Microsoft.SharePoint.Taxonomy.Term] LoadTerms(Microsoft.SharePoint.SPField)'


anyone??????????????

kmyhre Nov 8, 2011 at 5:08 PM 
I am having the same problem and it says that the error occured in the LoadTerms
0x1920 SmartTag Error 112 Unexpected Error occured in LoadTerms ExceptionType: 'NullReferenceException' ExceptionMessage: 'Object reference not set to an instance of an object.' StackTrace: ' at SmartTag.Common.Taxonomy.TaxonomyHelper.LoadTerms(SPField column)' Source: 'SmartTag.Common' TargetSite: 'System.Collections.Generic.List`1[Microsoft.SharePoint.Taxonomy.Term] LoadTerms(Microsoft.SharePoint.SPField)' 171d61a0-871c-435a-a3f9-75b51422917e

kmyhre Nov 8, 2011 at 5:02 PM 
I am having exactly the same problem with no additional language packs installed, English only.

thank you for any help available.
Windows Server 2008 R2 Standard, 64 Bit

AndreKrick Jul 6, 2011 at 7:56 PM 
Hello,

using smart tag I get the following error in ULS logs:
Error occured in LoadTerms ExceptionType: 'NullReferenceException' ExceptionMessage: 'Object reference not set to an instance of an object.' StackTrace: ' at SmartTag.Common.Taxonomy.TaxonomyHelper.LoadTerms(SPField column)' Source: 'SmartTag.Common' TargetSite: 'System.Collections.Generic.List`1[Microsoft.SharePoint.Taxonomy.Term] LoadTerms(Microsoft.SharePoint.SPField)'

System configuration is SharePoint 2010 Enterprise EN with German language pack installed.

Any help appriciated.

Kind regards,
André